[typo] Typo and FastCGI on Plesk VPS

Rida Al Barazi ralbarazi at gmail.com
Wed Sep 28 07:39:54 EDT 2005


Hi I already installed typo and it's working fine so far on CGI (except for the speed, which become better after cashing the files).
I tried to switch to fcgi but I was getting this error:

 [Wed Sep 28 10:42:29 2005] [alert] [client X.X.X.X] (2)No such file or directory: FastCGI: failed to connect to (dynamic) server "/home/httpd/vhosts/amidship.com/ruby/blog/public/dispatch.fcgi": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive, referer: http://www.amidship.com/admin 
[Wed Sep 28 10:42:29 2005] [error] [client X.X.X.X] FastCGI: incomplete headers (0 bytes) received from server "/home/httpd/vhosts/amidship.com/ruby/blog/public/dispatch.fcgi", referer: http://www.amidship.com/admin 

after checking online I followed what's in the link:

http://wiki.rubyonrails.com/rails/pages/HowtoSetupChrootedApacheWithRailsOnOpenBSD

But I got another error:

 [Wed Sep 28 11:04:37 2005] [error] [client X.X.X.X] FastCGI: comm with (dynamic) server "/home/httpd/vhosts/amidship.com/ruby/blog/public/dispatch.fcgi" aborted: (first read) idle timeout (30 sec) 
[Wed Sep 28 11:04:37 2005] [error] [client X.X.X.X] FastCGI: incomplete headers (0 bytes) received from server "/home/httpd/vhosts/amidship.com/ruby/blog/public/dispatch.fcgi"

I tried to copy the libraries as mentioned in the above link, but I couldn't find all of them, specifically the ld.so file.

Any help will be highly appreciated.. FYI I'm running on Plesk VPS server on Linux OS.

Another issue I'm facing also. and this is completely new and I didn't recognize what I did wrong so it's happening, if I add any article or do any change in the admin section, I'm getting Forbidden error message that won't go unless I chmod the public directory to 755 , but everytime I do changed I have to chmod again. any idea why this is happening?

Thanks in advance.

Rida
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20050928/b02fc6c2/attachment-0001.htm


More information about the Typo-list mailing list