[typo] problem installing typo on win xp

akonsu akonsu at gmail.com
Fri Sep 16 23:07:40 EDT 2005


hello, i downloaded typo 2.5.4 and followed the instructions in the README.

it seems to connect fine to mysql but gives me the error below. has anyone seen this?

i can connect to the database from mysql.exe with the same user and password and can execute
SHOW FIELDS FROM sessions with no problems manually.

thanks for any help
konstantin


#<ActiveRecord::StatementInvalid: Invalid argument: SHOW FIELDS FROM sessions>
["d:/programs/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib/active_record/
connection_adapters/abstract_adapter.rb:462:in `log'", "d:/programs/ruby/lib/rub
y/gems/1.8/gems/activerecord-1.11.1/lib/active_record/connection_adapters/mysql_
adapter.rb:121:in `execute'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/activerec
ord-1.11.1/lib/active_record/connection_adapters/mysql_adapter.rb:108:in `column
s'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib/active_rec
ord/base.rb:622:in `columns'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/activere
cord-1.11.1/lib/active_record/base.rb:627:in `columns_hash'", "d:/programs/ruby/
lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/session/active_rec
ord_store.rb:71:in `setup_sessid_compatibility!'", "d:/programs/ruby/lib/ruby/ge
ms/1.8/gems/actionpack-1.9.1/lib/action_controller/session/active_record_store.r
b:44:in `find_by_session_id'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/actionpa
ck-1.9.1/lib/action_controller/session/active_record_store.rb:243:in `initialize
'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_control
ler/session/active_record_store.rb:243:in `silence'", "d:/programs/ruby/lib/ruby
/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/session/active_record_stor
e.rb:243:in `initialize'", "d:/programs/ruby/lib/ruby/1.8/cgi/session.rb:273:in
`new'", "d:/programs/ruby/lib/ruby/1.8/cgi/session.rb:273:in `initialize'", "d:/
programs/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/cgi_
process.rb:94:in `new'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9
.1/lib/action_controller/cgi_process.rb:94:in `session'", "d:/programs/ruby/lib/
ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb:737:in `assign
_shortcuts'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/acti
on_controller/base.rb:351:in `process'", "d:/programs/ruby/lib/ruby/gems/1.8/gem
s/actionpack-1.9.1/lib/action_controller/rescue.rb:20:in `process_with_exception
'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/dispatcher.rb:34:i
n `dispatch'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/webrick
_server.rb:105:in `handle_dispatch'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/r
ails-0.13.1/lib/webrick_server.rb:71:in `service'", "d:/programs/ruby/lib/ruby/1
.8/webrick/httpserver.rb:104:in `service'", "d:/programs/ruby/lib/ruby/1.8/webri
ck/httpserver.rb:65:in `run'", "d:/programs/ruby/lib/ruby/1.8/webrick/server.rb:
155:in `start_thread'", "d:/programs/ruby/lib/ruby/1.8/webrick/server.rb:144:in
`start'", "d:/programs/ruby/lib/ruby/1.8/webrick/server.rb:144:in `start_thread'
", "d:/programs/ruby/lib/ruby/1.8/webrick/server.rb:94:in `start'", "d:/programs
/ruby/lib/ruby/1.8/webrick/server.rb:89:in `each'", "d:/programs/ruby/lib/ruby/1
.8/webrick/server.rb:89:in `start'", "d:/programs/ruby/lib/ruby/1.8/webrick/serv
er.rb:79:in `start'", "d:/programs/ruby/lib/ruby/1.8/webrick/server.rb:79:in `st
art'", "d:/programs/ruby/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/webrick_server.
rb:57:in `dispatch'", "script/server:49"]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20050916/da27942b/attachment.htm


More information about the Typo-list mailing list