[typo] Another Frustrating Dreamhost/Rails/Typo experience

Scott Laird scott at sigkill.org
Tue Sep 6 17:28:19 EDT 2005

On Sep 6, 2005, at 2:17 PM, Mike Purvis wrote:
> Greetings List,
> I'm new to Rails and Ruby, but a reasonably experienced PHP/MySQL  
> hacker. I seem to be have some problems similar to those discussed  
> here a few weeks ago.
> My Typo installation (http://mikepurvis.com) works when set to  
> dispatch.cgi, but it's Ruby on Snails. When I point to the fcgi  
> dispatcher, it's nice and brisk until it seizes up and then I get  
> 500s (represented by the "Typo Not Available" error...)
> At the moment of writing, it seems to be running, although "ps ax"  
> on the server shows 15 running dispatch.fcgi processes.
> I'm running Typo from SVN (about 24 hours ago), and it's Ruby  
> 1.8.2. The version of rails I'm not sure about.
> Okay, now it's going slow as molasses and the server is showing 8  
> running processes including one that's "defunct".
> Any suggestions?

Try switching from dynamic fcgi to static fcgi.  It'll result in a  
lower load for your hosting provider and faster (and more reliable)  
performance for you.  I'm not sure how you do this with dreamhost,  

I documented what I did at http://scottstuff.net/blog/articles/ 
2005/07/19/apache-tuning-for-rails-and-fastcgi.  You might want to  
turn the number of processes down to 1 or 2; with caching enabled,  
there shouldn't be a big performance difference, and it'll save a lot  
of memory.


More information about the Typo-list mailing list