[typo] Moving to Latest SVN

jesse newland jnewland at gmail.com
Sat Oct 15 11:03:02 EDT 2005


I had this same error last night. The problem seemed to happen (for me
anyways) just after adding guid's to comments and trackbacks. Here's
what I did to fix this and get back to the trunk:

* Backup DB and any modifications to typo
* Revert to revision 636
* Manually remove the dbname.comments.guid, and dbname.trackbacks.guid
columns. (if they exist)
* Run rake migrate
* Update to trunk
* Run rake migrate
* Re-hack typo to your liking

Revision 636 introduced guid's for comments and trackbacks, which
requires re-saving of all such records. Later revisions of typo have
renamed the 'articles' table to 'contents', which makes this re-saving
difficult.  Hope this works.

Jesse

On 10/15/05, Scott Laird <scott at sigkill.org> wrote:
>
> On Oct 15, 2005, at 5:59 AM, gpshewan wrote:
>
> > I don't know if it's just me, but I've never managed to upgrade from
> > 2.5.4 to the latest trunk.  I always get the "dbname.contents table
> > does not exist" issue every time I run rake migrate.
> >
> > Anybody else seen this?  Or am I alone and in trouble? :)
>
> Can you open a bug for this?  Now that you mention it, I can see how
> this would happen, but I don't have time to fix it right now.
> Possibly later today, though.
>
>
> Scott
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>


--
jnewland at gmail.com
jnewland.com
AIM: jbnewland
706.340.3625



More information about the Typo-list mailing list