[typo] kaboom?

Hal Fulton hal9000 at hypermetrics.com
Thu Oct 6 20:55:44 EDT 2005


Hi, all...

I've done something stupid apparently. Kudos to anyone who
can help fix.

Here's how it went:

1. I saved off my database.yml and did an update. Apparently
I failed to notice that some files had conflicts. (Why they
would, I don't know. I hadn't changed any of them manually.)

2. I restarted the server and went to admin.

3. It told me I needed to migrate -- 18 to 23, if I recall.

4, So I hit the button. Got "Rails App Error"

5. Went and looked at log. Oh, damn. Syntax error on a line
that says "<<< mine" or something. Believe it was the file
app/controllers/xml_controller.rb

6. Fixed it manually -- think I got it right. But I should
have realized I had a partial migration in an undefined
state.

7. Restarted server. Now it tells me 21 to 23. Still app
error though.

8. Tried migrate at command line. This happens:

    [root at www typo]# rake migrate RAILS_ENV=production
    (in /root/typo)
    Extending Content table
    Converting trackbacks
    rake aborted!
    Couldn't find Article without an ID
    ./Rakefile:218


Help??

Hal



More information about the Typo-list mailing list