[typo] flickr XMLRPC not working?

Scott Laird scott at sigkill.org
Sun Nov 20 18:51:31 EST 2005


On Nov 20, 2005, at 3:40 PM, Victor Jalencas wrote:

> Scott Laird wrote:
>> On Nov 20, 2005, at 11:59 AM, Victor Jalencas wrote:
>>
>>> Joerg Battermann wrote:
>>>> Hey there,
>>>>
>>>> I use(d) the movable-type api at flickr for a picture-based blog-
>>>> entry
>>>> every now and then, but it seems flickr now automatically assumes,
>>>> that
>>>> the xmlrpc backend is located under "/backend/xmlrpc/mt-
>>>> xmlrpc.cgi". I
>>>> re-added my blog in my flicker account's settings, and it  
>>>> detected it
>>>> fine using the actual typo-url, but after validating et all, it  
>>>> again
>>>> uses the url above :\
>>>>
>>>> it's definetly a flickr bug from what I can tell...
>>>>
>>> Can we have a bit of routing magic as a workaround, while flickr  
>>> fixes
>>> its act up?
>>
>> If you look at the bug in trac, they're finding our API okay, but
>> then asking for metaweblog.getUsersBlogs, which doesn't exist.  Since
>> the metaweblog API spec doesn't list a getUsersBlogs, it's hard to
>> implement it.
>>
>
> That's right, I didn't check trac, I just went by Joerg  
> description. No
> wonder it is failing, since it is a blogger API method [1]. I  
> wonder if
> we could implement it as per Blogger's spec, since being Typo a
> single-blog-per-user engine, getting the URL of the XMLRPC endpoint
> wouldn't be much difficult.

The blogger API call works, and *everything* uses it.

It's the metaweblog call that Flickr seems to be intent on inventing.


Scott



More information about the Typo-list mailing list