[typo] Typo does not work any more

Bart Braem bart.braem at gmail.com
Thu Nov 17 13:35:02 EST 2005


On 11/17/05, Scott Laird <scott at sigkill.org> wrote:
>
> Okay, try running ./script/console and then typing this:
>
>    Article.find(:all).size
>
> That *should* return the total number of articles that you have
> defined.  I suspect that it will actually end up giving you an error
> message.
>
>
That's more like it:
oading development environment.
>> Article.find(:all).size
ActiveRecord::StatementInvalid: Lost connection to MySQL server during
query: SELECT * FROM articles
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/abstract_adapter.rb:67:in
`log'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:164:in
`execute'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:297:in
`select'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:143:in
`select_all'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:447:in
`find_by_sql'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:411:in
`find'
        from (irb):1
        from :0
But my and login work. Strange...

Thanks for your help,
Bart
--
"May the source be with you"



More information about the Typo-list mailing list