[typo] typo & dreamhost

James Moore jam at wirerimmed.com
Fri Nov 11 13:58:14 EST 2005

On Nov 11, 2005, at 8:24 AM, patrick kranzlmüller wrote:

> i´ve tried to setup typo on dreamhost for a couple of hours now - i
> read every tutorial and discussion about that topic. and still, it
> doesn´t work.
> problems:
> on the website, i get "application error: typo could not be reached"
> when trying to run public/dispatch.fcgi (or public/dispatch.cgi) from
> the shell, i get "status 500: internal server error"
> the log-files don´t seem to be updated (though they are writeable)
> configuration:
> .htaccess is on the server and configured correctly
> shebang-line in dispatch.cgi and dispatch.fcgi is #!/usr/bin/ruby
> database-connection is ok (tried that with another app)
> no subdirectory

Run ./script/server and then hit your site on port 3000 (or whereever  
the server says its running). Try to go directly to /admin. If you  
can access that page save the default settings and then go to the  
themes tab. If the default theme isn't active, activate it and then  
try going to the normal URL.

After successfully upgrading to 2.6.0 I came back the next day and my  
site was dead. The logs were claiming zero-length responses from  
dispatch.fgci. When I would go to the front page via the built-in  
server I would simply get a theme path written to my browser. After  
much messing around I discovered that no theme was active. I don't  
know how I got into this state but there certainly needs to be some  
kind of exception thrown to the browser when typo is in this state.


More information about the Typo-list mailing list