[typo] typo & dreamhost

Mike Purvis mike at uwmike.com
Fri Nov 11 12:08:24 EST 2005


Hi Patrick,

I had very similar problems to what you're describing, but I'm afraid I 
still don't know exactly what caused them to cease. But my dispatch.fcgi 
shebang is "#!/usr/bin/env ruby"

Try switching between development and production mode. (variable at the 
top of /config/environment.rb)

Also, be sure to dump the appropriate schema from /db into your 
database. If it can't find its tables, it seems to fail without warning.

Just remember, "Typo could not be reached" is a catch-all for 500s... 
could really be anything.

Mike


patrick kranzlmüller wrote:

>i´ve tried to setup typo on dreamhost for a couple of hours now - i 
>read every tutorial and discussion about that topic. and still, it 
>doesn´t work.
>
>problems:
>on the website, i get "application error: typo could not be reached"
>when trying to run public/dispatch.fcgi (or public/dispatch.cgi) from 
>the shell, i get "status 500: internal server error"
>the log-files don´t seem to be updated (though they are writeable)
>
>configuration:
>.htaccess is on the server and configured correctly
>shebang-line in dispatch.cgi and dispatch.fcgi is #!/usr/bin/ruby
>database-connection is ok (tried that with another app)
>no subdirectory
>
>any help is appreciated.
>  
>


More information about the Typo-list mailing list