[typo] Best upgrade path?

Scott Laird scott at sigkill.org
Fri Nov 11 00:08:21 EST 2005


On Nov 10, 2005, at 7:43 PM, Hal Fulton wrote:
> Hal Fulton wrote:
>
>>    Rails 0.10.1   Theoretically unsupported?
>
> Sorry, did that in wrong window. I'm running 0.13.1

You should be able to upgrade to Typo 2.6.0 without many problems.   
It'll run fine with Ruby 1.8.2 and Rails 0.13.1, *except* for one  
line--the last line in environment.rb fixes a Rails problem that  
doesn't exist in 0.13.1, and the 'rescue nil' isn't strong enough to  
catch the exception that it generates on 0.13.1, unfortunately.

If you want to upgrade to the trunk, then you'll need to upgrade to  
Rails 0.14.2 or higher.  Make sure that you back up your DB, but I've  
had a lot of positive reports from people upgrading.  Or you can wait  
for a few weeks until we've finished testing it, and the upgrade will  
(hopefully) work better.


Scott


More information about the Typo-list mailing list