[typo] Typo 2.5.0

Nicholas Van Weerdenburg vanweerd at gmail.com
Wed Nov 2 20:56:46 EST 2005

What kind of issues might I expect running Typo 2.5.0 on Rails 0.14.2?

The code has some modifications, so it will take a bit of effort to
move it to a later Typo.

The reason I ask is that Textdrive moved to 0.14.2

I tried the following in environment.rb
# Set use_latest=true for latest gem install
# otherwise use 0.13.1 version of Rails
use_latest = false

if use_latest
  require 'active_support'
  require 'active_record'
  require 'action_controller'
  require 'action_mailer'
  require 'action_web_service'
  require_gem 'activesupport', '= 1.1.1'
  require_gem 'actionwebservice', '= 0.8.1'
  require_gem 'activerecord', '= 1.11.1'
  require_gem 'actionpack', '= 1.9.1'
  require_gem 'actionmailer', '= 1.0.1'
  require_gem 'rails', '= 0.13.1'

But that caused the following error:

ruby script/server
ncies.rb:186:in `const_missing': uninitialized constant ActiveRecordStore (Na
        from ./script/../config/environment.rb:109
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
        from script/server:42

Any thoughts on that one?

Finally, I considered the "rails ." upgrade step, but I figured that
was too risked so I reverted out of it.

Alternatively, the app does seems to run on 0.14.2 if I don't make any
changes, but I'm wondering what kind of issues that might cause me.


More information about the Typo-list mailing list