[typo] Migrate issues

Ron Green ronald.green at gmail.com
Wed Nov 2 10:57:30 EST 2005

I am using the schema file in db.
The migrate thing is happening all on its own.
All I am doing is running the schema and then (using webrick) go to
I get the initial admin new user screen user name, email password and then
press setup. At this point I am presented with the migrate screen. It's not
a choice.
I even went so far as to delete ruby, rails, apache, mysql, typo and
reinstall all to get a fresh start.

 On 11/2/05, Scott Laird <scott at sigkill.org> wrote:
> On Nov 2, 2005, at 5:46 AM, Ron Green wrote:
> > If I try to install 2.5.6, when I log in to admin the first time,
> > it presents me with the DB migration page which indicates I am
> > eligible to migrage from 0 to 9. If I try installing from trunk, I
> > get the same thing only it says I am eligible to migrate from 0 to
> > 24. The db migration never works. It starts throwing exceptions
> > that columns or table already exist. I tried following through one
> > of the 0 to 9 migrations. Every time it threw an exception, I would
> > delete whatever it was in the schema. Finally got to the end and
> > nothing happened. If I tried hitting migrate again, the process
> > started all over again.
> Don't try to migrate to set up the initial DB--use the schema files
> in db/schema.*.sql instead. The migrator in shouldn't offer to
> migrate from schema 0--that's really a bug that we need to fix.
> Scott
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20051102/aa262246/attachment.htm

More information about the Typo-list mailing list