[typo] Migrate issues

Scott Laird scott at sigkill.org
Wed Nov 2 09:45:13 EST 2005


On Nov 2, 2005, at 5:46 AM, Ron Green wrote:

> If I try to install 2.5.6, when I log in to admin the first time,  
> it presents me with the DB migration page which indicates I am  
> eligible to migrage from 0 to 9. If I try installing from trunk, I  
> get the same thing only it says I am eligible to migrate from 0 to  
> 24. The db migration never works. It starts throwing exceptions  
> that columns or table already exist. I tried following through one  
> of the 0 to 9 migrations. Every time it threw an exception, I would  
> delete whatever it was in the schema. Finally got to the end and  
> nothing happened. If I tried hitting migrate again, the process  
> started all over again.

Don't try to migrate to set up the initial DB--use the schema files  
in db/schema.*.sql instead.  The migrator in shouldn't offer to  
migrate from schema 0--that's really a bug that we need to fix.


Scott


More information about the Typo-list mailing list