[typo] Memory usage

Sean Treadway seant at superchannel.org
Thu May 12 11:41:53 EDT 2005


Hey Robby,

There is a known memory leak in the 0.8.5 Ruby FastCGI module.  You  
should verify that you have 0.8.6 installed.

-Sean

On May 12, 2005, at 5:23 PM, Robby Russell wrote:

> On Thu, 2005-05-12 at 06:48 -0700, Robby Russell wrote:
>
>> I am noticing that Typo overtime begins to take up a bit of  
>> resources.
>>
>> Having restarted apache about 45 mins ago, I am noticing that my  
>> blog is
>> already using 51M on the fastcgi process.
>>
>> Is this normal behavior?
>>
>> I am going to keep watching it, but wondering if there could be a  
>> memory
>> leak somewhere or is there anything that I can do to have the process
>> restart itself after so much time or usage?
>>
>> -Robby
>>
>>
>
> I'm still watching the process. A hour and a half since my last email:
>
>
>   PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU
> COMMAND
> 12304 apache    16   0  105M 105M  2372 S     0.0 10.4   1:53   0
> dispatch.fcgi
>
> -Robby
>
> -- 
> /******************************************************
> * Robby Russell, Owner.Developer.Geek
> * PLANET ARGON, Open Source Solutions & Web Hosting
> * Portland, Oregon | p: 503.351.4730 | f: 815.642.4068
> * www.planetargon.com | www.robbyonrails.com
> *******************************************************/
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>



More information about the Typo-list mailing list