[typo] trackback urls

Jesse Andrews anotherjesse at gmail.com
Fri May 6 14:45:11 EDT 2005


in view/article/read.rhtml - 

<%= server_url_for :controller=>"articles", :action=>"trackback",
:id=>@article.id %>

server_url_for is the culprit.

You can fix it by using relative links (don't include the ip) probably...

<%= link_to 'trackback', :controller=>'articles',
:action=>'trackback', :id=>@article.id %>

that worked for me.

On 5/6/05, Robby Russell <robby at planetargon.com> wrote:
> On Fri, 2005-05-06 at 11:35 -0700, Robby Russell wrote:
> > We at Planet Argon hosting typo blogs and I just noticed something.
> >
> 
> Oops, that came out weird. heh. "We at Planet Argon *our*
> hosting..." :-)
> 
> 
> > If we're running typo on a different port and using a proxy to filter
> > through port 80, on the site, the trackback link shows the port.
> >
> > Use the following link to trackback from your own site:
> > http://www.domainname.com:8580/articles/trackback/1
> >
> > Where should I look to make a fix for this? Is it necessary to have it
> > display the port for the trackback?
> >
> > I don't see any other links in the html that show that.
> >
> > Thanks,
> >
> > -Robby
> >
> >
> --
> /******************************************************
> * Robby Russell, Owner.Developer.Geek
> * PLANET ARGON, Open Source Solutions & Web Hosting
> * Portland, Oregon | p: 503.351.4730 | f: 815.642.4068
> * www.planetargon.com | www.robbyonrails.com
> *******************************************************/
> 
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>



More information about the Typo-list mailing list