[typo] How do you upgrade the database schema from typo 1.0 to 2.0

Tobias Luetke tobias.luetke at gmail.com
Thu Jun 16 11:31:14 EDT 2005


Hmm downgrading to fcgi 0.8.5 is not really an option and you should
not advocate it. fcgi 0.8.5 has a huge memory leak. I made the 0.8.6
gem so please tell me what problems you where seeing so that I can
update the gem.

On 6/16/05, Patrick Chanezon <chanezon at gmail.com> wrote:
> Thanks to all, sorry, I had not seen the upgrade script.
> It works fine.
> I had other problems not linked to typo, but to fastcgi, that I
> documented on my blog.
> 
> I just moved my blog to typo 2 now.
> http://blog.chanezon.com/articles/2005/06/16/migrating-to-typo-2
> 
> P@
> 
> 
> On 6/15/05, Chris McGrath <c.r.mcgrath at gmail.com> wrote:
> > What I did was save all my old posts using MarsEdit, change my site to
> > my typo2 install, and submit them all back. I had to fix up the
> > categories and which markup language to use, and still have to fix up
> > the posting dates.
> >
> > This might not be a scalable solution if you have lots of posts though.
> >
> > Chris
> >
> > On 6/15/05, Patrick Chanezon <chanezon at gmail.com> wrote:
> > > Hi all,
> > > I'm moving from Typo 1.0 to 2.0 these days.
> > > I succeeded into moving all my code changes.
> > > But the database schema has changed a little bit.
> > > How do you typically do your migration? dump / new schema / restore?
> > >
> > > _______________________________________________
> > > Typo-list mailing list
> > > Typo-list at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/typo-list
> > >
> >
> 
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
> 


-- 
Tobi
http://www.snowdevil.ca - Snowboards that don't suck
http://typo.leetsoft.com - Open source weblog engine
http://blog.leetsoft.com - Technical weblog



More information about the Typo-list mailing list