[typo] Upgade errors

Robin Bowes robin-lists at robinbowes.com
Tue Jul 26 12:58:39 EDT 2005


I just did an svn update to r455 and am having problems migrating.

Firstly, my site (http://typo.robinbowes.com) shows no stylesheet, but I 
guess that is due to the recent changes and I should be able to fix this 
through the admin interace.

When I go to the admin interface, I have no option but to upgrade my db 
schema (from 1 to 7). When I chose "Update database now" I get the 
following error in my production.log:

   NoMethodError (undefined method `find_by_name' for User:Class):

Then, subsequent updates fail with;

   ActiveRecord::StatementInvalid (ERROR:  column "user_id" of relation 
"articles" already exists

This is because the user_id column gets added but the schema version 
doesn't get bumped in schema_info because of the initial error.

I manually bumped the version to 3 and manually populated the user_id 

I'm now at the stage of migrating from schema rev 3 to schema rev 7.

When I choose "Update database now" I get the following error in the log;

   ActiveRecord::StatementInvalid (ERROR:  relation "page_caches" does 
not exist

The sidebars table gets created. but not populated with any data.

The schema is at rev 3 still.

I manually bumped the schema to rev 4 and tried again:

Migrating to AddCacheTable (5)
Migrating to AddPages (6)
Migrating to AddPermalink (7)

These seem to have worked OK.

I can now access the admin screen OK and all the admin functions seem to 
work fine.

However, I'm still not seeing a style sheet on my blog.

I tried the fix suggested in a previous post to this list:

"You need to save your general settings once and then pick 'activate' 
in the themes admin next to the only available theme 'azure' to make 
sure your blog has all the settings it needs. We're working on a more 
friendly solution here."

This didn't seem to work - I still get no stylesheet.

Looking in the log, it's trying to access /stylesheets/azure.css but I 
get the following log:

ActionController::RoutingError (Recognition failed for 

There is no  azure.css in public/stylesheets/ so I copied azure.css 
there and bingo! it all seems to work now.

I hope this is useful feedback!

I've also posted an edited version of this at:


Incidentally, how do I get this to appear on the front page?


If a man speaks in a forest,
and his wife's not there,
is he still wrong?	

More information about the Typo-list mailing list