[typo] Migrate error in latest version

Piers Cawley pdcawley at bofh.org.uk
Thu Dec 8 13:29:59 EST 2005


Dusty Jewett <dusty.jewett at gmail.com> writes:

> ok, here's what I've got...
> original install: 2.6...
> decided to jump to latest, rm -R'd all of the old code, svn'd in the newest
> code (as in the example previously), svn'd the latest rails, and I get this
> error when attempting to migrate. Is this a typo or rails error?

That was a temporary typo error caused by an idiot who forgot to add some files
to his patch. I know he's an idiot 'cos I see him in the mirror every day. 

The upgrade from 2.6.0 is currently not as smooth as it could be though because
the changes to schema version 33 make things break (and the usual trick for
working around it won't work here...) 

You should be able to work around it for now by doing it in two stages. First
check out revision 757 (just add -r 767 to your checkout line) and go to the
admin interface to upgrade the database. Then do 'svn up -r HEAD' and run the
rest of the migration. I've got other commitments today so I can't make a patch
to fix things, but I'll get on it as soon as I can.

-- 
Piers Cawley <pdcawley at bofh.org.uk>
http://www.bofh.org.uk/


More information about the Typo-list mailing list