[typo] Migrate error in latest version

Dusty Jewett dusty.jewett at gmail.com
Wed Dec 7 19:19:00 EST 2005


any clue if there is a workaround for people on shared hosting and don't
have access to edit the ruby files?

On 12/7/05, Peter Donald <peter.j.donald at gmail.com> wrote:
>
> Hi,
>
> I think it depends on the version of rails you are using - I am using
> 0.14.3 but it may be present in other versions. What I did was go into
> the documentation.rake file in the rails plugin. On windows this is
> located at $RUBY_HOME\lib\ruby\gems\1.8\gems\rails-
> 0.14.3\lib\tasks\documentation.rake
>
> In this file they use
>
> Plugins = FileList...
>
> And refer to Plugins a few more times in that file. Just replace it
> with "plugins" (ie make p lowercase) and it should work.
>
> Hope that helps.
>
> --
> Cheers,
>
> Peter Donald
>
> Blog: http://www.RealityForge.org
>
>
> On 12/7/05, Dusty Jewett <dusty.jewett at gmail.com> wrote:
> > Peter,
> > I'm getting this error too, how did you fix this?
> >
> > -Dusty
> >
> > On 12/4/05, Peter Donald <peter at realityforge.org > wrote:
> > > Hi,
> > >
> > > Ignore this it is a bug in rails. Sorry for the noise.
> > >
> > > Peter Donald wrote:
> > > > Hi,
> > > >
> > > > I just retrieved the latest version of typo from subversion and
> > > > attempted to migrate from version 28 to latest and I get the
> following
> > > > error. Anyone got any ideas? (I am on Rails 0.14.3)
> > > >
> > > > F:\Projects\typo>rake migrate --trace
> > > > (in F:/Projects/typo)
> > > > ** Invoke migrate (first_time)
> > > > ** Invoke environment (first_time)
> > > > ** Execute environment
> > > > ** Execute migrate
> > > > rake aborted!
> > > >  is not a class/module
> > > >
> > ./config/../components/plugins/textfilters/amazon_controller.rb:1
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:207:in `load'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:207:in `load'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:39:in `require_or_load'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:22:in `depend_on'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-
> > 1.2.3/lib/active_suppo
> > > > rt/dependencies.rb:178:in `require_dependency'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:178:in `require_dependency'
> > > >
> > ./config/../app/controllers/textfilter_controller.rb:108
> > > >
> > ./config/../app/controllers/textfilter_controller.rb:107:in
> > `each'
> > > >
> > ./config/../app/controllers/textfilter_controller.rb:107
> > > >
> >
> c:/applications/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
> > `re
> > > > quire__'
> > > >
> >
> c:/applications/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
> > `re
> > > > quire'
> > > >
> > c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3
> /lib/active_suppo
> > > > rt/dependencies.rb:214:in `require'
> > > > ./config/../app/models/text_filter.rb:2
> > > > ...
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20051207/ec2e367d/attachment.htm


More information about the Typo-list mailing list