[typo] install error 500

Dusty Jewett dusty.jewett at gmail.com
Wed Dec 7 06:23:37 EST 2005


If it says table not found, I'm guessing that you haven't run the .sql file.
Unline wordpress/mt, the "installation" doesn't happen automagically, you're
gonna have to load and run the schema file for whatever database you are
using.

-Dusty

On 12/6/05, Peter Kröpfl <peter at groebi.com> wrote:
>
> >
> Hi,
>
> like some others I get an error 500 when I try to start up typo using:
>
> $ ruby script/server -e production
> => Rails application started on http://0.0.0.0:3000
> => Ctrl-C to shutdown server; call with --help for options
> [2005-12-06 23:36:35] INFO  WEBrick 1.3.1
> [2005-12-06 23:36:35] INFO  ruby 1.8.3 (2005-06-23) [i486-linux]
> [2005-12-06 23:36:35] INFO  WEBrick::HTTPServer#start: pid=29291
> port=3000
> 127.0.0.1 - - [06/Dec/2005:23:36:43 CET] "GET / HTTP/1.1" 500 0
> - -> /
>
> Pointing the browser to http://localhost:3000/ I only get a blank page.
> Interestingly if I point the browser to localhost:3000/500.html the html
> page
> will be shown.
>
>
> The connection to the database should be OK I guess, because if I try
> the following I get an error saying that a table can not be found.
> Which is obvious, because typo  installation has not been started yet,
> so no tables have been created.
>
> $ ./script/console
> Loading development environment.
> >> Article.find(:all)
> ActiveRecord::StatementInvalid: FEHLER:  Relation »articles« existiert
> nicht : SELECT * FROM articles
>
>
> the log directory and the files are writable, but the logfiles do not
> show any output.
>
>
> running dispatch from the command line gives error 500 again:
>
> $ public/dispatch.fcgi
> Status: 500 Internal Server Error
> $ ruby public/dispatch.rb
> Status: 500 Internal Server Error
>
>
> I have no idea what else could be wrong, or what else to check. Please
> help! I have no idea what else I could try, maybe someone else has.
>
> Thanks,
> Peter
>
>
> My Configuration:
>
> I am running Ubuntu Breezy (5.10)
> $ ruby --version
> ruby 1.8.3 (2005-06-23) [i486-linux]
>
> $ rails --version
> Rails 0.14.3
>
> $ psql --version
> psql (PostgreSQL) 7.4.8
>
> $ sudo gem list
> Password:
>
> *** LOCAL GEMS ***
>
> actionmailer (1.1.3)
>     Service layer for easy email delivery and testing.
>
> actionpack (1.11.0)
>     Web-flow and rendering framework putting the VC in MVC.
>
> actionwebservice (0.9.3)
>     Web service support for Action Pack.
>
> activerecord (1.13.0)
>     Implements the ActiveRecord pattern for ORM.
>
> activesupport (1.2.3)
>     Support and utility classes used by the Rails framework.
>
> fcgi (0.8.6.1)
>     FastCGI ruby binding.
>
> postgres (0.7.1)
>     The extension library to access a PostgreSQL database from Ruby.
>
> rails (0.14.3)
>     Web-application framework with template engine, control-flow layer,
>     and ORM.
>
> rake (0.6.2)
>     Ruby based make-like utility.
>
> rubygems-update (0.8.11)
>     RubyGems Update GEM
>
> sources (0.0.1)
>     This package provides download sources for remote gem installation
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20051207/9143da58/attachment-0001.htm


More information about the Typo-list mailing list