[typo] Jabber issue in Build 764

Ernie Oporto ernieoporto at gmail.com
Tue Dec 6 21:50:54 EST 2005


Bingo.  In my case it was restarting Apache, but that did the trick.
Ernie


On 12/5/05, Scott Laird <scott at sigkill.org> wrote:
>
> Oh, I see.
> Restart Typo (either Webrick or dispatch.fcgi).  I don't think it picked
> up on the DB changes internally.  I'll look into fixing that, but restarting
> should do the job.
>
>
> Scott
>
> On Dec 5, 2005, at 6:28 AM, Ernie Oporto wrote:
>
>
>
> The fields were definitely added in the migration...
>
> CREATE TABLE `users` (
>   `id` int(11) NOT NULL auto_increment,
>   `login` varchar(80) default NULL,
>   `password` varchar(40) default NULL,
>   `name` varchar(80) default NULL,
>   `email` varchar(80) default NULL,
>   `notify_via_email` tinyint(1) default NULL,
>   `notify_on_new_articles` tinyint(1) default NULL,
>   `notify_on_comments` tinyint(1) default NULL,
>   `notify_watch_my_articles` tinyint(1) default NULL,
>   `notify_via_jabber` tinyint(1) default NULL,
>   `jabber` varchar(255) default NULL,
>   PRIMARY KEY  (`id`),
>   UNIQUE KEY `login` (`login`)
> ) ENGINE=InnoDB DEFAULT CHARSET=latin1 AUTO_INCREMENT=3 ;
>
>
>
>
>
> On 12/4/05, Scott Laird <scott at sigkill.org> wrote:
> >
> > Can you describe your 'users' table?  Migration #32 *should* have added
> > this field.  On the other hand, you're certainly not the only person
> > complaining about similar problems, so I'm not sure what's up.
> >
> > Scott
> >
> > On Dec 4, 2005, at 2:43 PM, Ernie Oporto wrote:
> >
> > After an upgrade to build 764<http://typo.leetsoft.com/trac/changeset/764>from the trunk, I am seeing this error message when trying to add a new
> > User.  Not a showstopper, but thought someone would like to know, and to
> > make sure that I'm not screwing anything up myself.  Of course, that's what
> > happens when you live on the bleeding edge of recent non-release builds. =)
> > Everything else works nicely.
> >
> >
> > ActionView::TemplateError (undefined method `jabber' for
> > #<User:0x408a7360>) on
> > line #17 of app/views/admin/users/_form.rhtml:14: </p>
> > 15: <p>16: <label for="user_jabber">Jabber:</label> <small>(this can be
> > blank)</small><
> > br/>17: <%= text_field 'user', 'jabber'  %>
> > 18: </p>19: <p>
> > 20:   <label for="user_password">Password:</label><br />
> >     /usr/lib/ruby/gems/1.8/gems/activerecord- 1.13.0.2969/lib/active_record/base.rb:1497:in
> > `method_missing'
> >     /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969
> > /lib/action_view/helpers/f
> > orm_helper.rb:254:in `value_before_type_cast'
> >     /usr/lib/ruby/gems/1.8/gems/actionpack- 1.11.0.2969/lib/action_view/helpers/form_helper.rb:168:in
> > `to_input_field_tag'
> >     /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969/lib/action_view/helpers/form_helper.rb:76:in
> > `text_field'
> >
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
> >
> >
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
> >
> >
> >
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
>
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20051206/04276711/attachment.htm


More information about the Typo-list mailing list