[typo] Migrate error in latest version

Peter Donald peter.j.donald at gmail.com
Mon Dec 5 02:01:40 EST 2005


Hi,

I just retrieved the latest version of typo from subversion and
attempted to migrate from version 28 to latest and I get the following
error. Anyone got any ideas? (I am on Rails 0.14.3)

F:\Projects\typo>rake migrate --trace
(in F:/Projects/typo)
** Invoke migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute migrate
rake aborted!
 is not a class/module
./config/../components/plugins/textfilters/amazon_controller.rb:1
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:207:in `load'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:207:in `load'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:39:in `require_or_load'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:22:in `depend_on'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:178:in `require_dependency'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:178:in `require_dependency'
./config/../app/controllers/textfilter_controller.rb:108
./config/../app/controllers/textfilter_controller.rb:107:in `each'
./config/../app/controllers/textfilter_controller.rb:107
c:/applications/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in `re
quire__'
c:/applications/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in `re
quire'
c:/applications/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_suppo
rt/dependencies.rb:214:in `require'
./config/../app/models/text_filter.rb:2
...

--
Cheers,

Peter Donald



More information about the Typo-list mailing list