[typo] Frustrating Dreamhost/Typo experience

Scott Hughes (List) shughes_list at globalreset.org
Thu Aug 25 16:53:58 EDT 2005


On Aug 25, 2005, at 3:28 PM, gpshewan wrote:
> I had the same issues when I first switched Scott.  Everything  
> seems fine
> now though.  DH just switched to production for rails, so are you  
> forcing
> that in config/environments?
>
> RAILS_ENV  = ENV['RAILS_ENV'] || 'production'
>
> I know you said you tried running in 'developer' mode, but just double
> checking.  This was the last thing I remember doing to my install.
>
> I know what you are experiencing though.  I found the timeouts very
> annoying.
>
> Gary Shewan

Gary,

My environments file had the following line:

RAILS_ENV  = ENV['RAILS_ENV'] || 'development'

I was assuming that when DH said it switched to production, that  
meant ENV['RAILS_ENV']='production'.  To be on the safe side, I've  
changed this line to:

RAILS_ENV  = 'production'

After I made that change, I did another "killall -9 dispatch.fcgi;  
rake sweep_cache" (even though it wasn't locked up) and I noticed  
that it started responding again immediately.  I don't know if this  
is because it wasn't locked up before I killed it or if it is because  
of the environment change.  I will report back tomorrow if I  
experience any more lockups after this change.

Also, when I said that I tried running in 'developer' mode, I meant  
with "script/server -e development" and using port 3000.  I guess  
this means I used WeBrick (but I'm still learning the lingo).

Scott



More information about the Typo-list mailing list