[typo] Frustrating Dreamhost/Typo experience

gpshewan gpsnospam at gmail.com
Thu Aug 25 16:28:46 EDT 2005

I had the same issues when I first switched Scott.  Everything seems fine
now though.  DH just switched to production for rails, so are you forcing
that in config/environments?

RAILS_ENV  = ENV['RAILS_ENV'] || 'production'

I know you said you tried running in 'developer' mode, but just double
checking.  This was the last thing I remember doing to my install.

I know what you are experiencing though.  I found the timeouts very

Gary Shewan

-----Original Message-----
From: typo-list-bounces at rubyforge.org
[mailto:typo-list-bounces at rubyforge.org] On Behalf Of Scott Hughes (List)
Sent: 25 August 2005 21:11
To: typo-list at rubyforge.org
Subject: [typo] Frustrating Dreamhost/Typo experience

Hi all...  I'm new to the Typo mailing list and to RubyOnRails  
development  (my agile book is in the mail).  I'm having a bit of an  
annoying experience with Typo on Dreamhost.  I'm running out of SVN  
(from approximately 7 days ago) and I'm getting frequent lockups/ 

I looked through my apache error log and I don't see anything  
particularly illuminating...  Just a few errors where dispatch.fcgi  
returned 0 bytes.  Doesn't give much else for info.  The production  
log looks fine, except for an occasional missing image (which btw, is  
not referenced by my stylesheet or my default.rhtml, so I don't know  
where this image is being requested and how it got lost).  Whenever  
Typo is not responding, a 'ps ax' shows a dozen or so dispatch.fcgi  
processes running (some defunct).

I've tried running in developer mode, and watching the output, but I  
can't reproduce a timeout condition when doing so.  My blog probably  
gets 10-30 real hits a day, and over 300 hits by robots.  I don't  
know if the robots are what's causing the problem.

After a while of waiting for it to "fix itself", I end up doing a  
"killall -9 dispatch.fcgi;  rake sweep_cache" and wait about 15-20  
minutes for it to start working again.  I don't know if that's the  
best procedure for reseting it or not...  And I'm really curious as  
to why it takes 15-20 minutes to start working again.

I looked at the rails troubleshooting tips on the Rails wiki, but  
nothing helped.  Does anyone have any tips (which I could add to the  
wiki) that could help me debug this?  Or is anyone aware of any  
gotchas for Dreamhost installation?  All I did to install was ftp the  
files over (that I had svn'ed to my local Mac), setup my database,  
import my wordpress articles, and point a subdomain at the path to  
Typo (with fcgi enabled).  I had to "chmod +x public/* script/*"...   
And I've modified my own copy of the default theme.  But that's it..   
It's a fairly vanilla installation.

Thanks for any help.

Scott Hughes
Typo-list mailing list
Typo-list at rubyforge.org

More information about the Typo-list mailing list