[typo] Running in production mode on FastCGI

Trejkaz trejkaz at trypticon.org
Sat Aug 13 19:20:31 EDT 2005

FastCGI seems to have worked straight out of the box for development mode.

I've been starting to set up the production version on a different vhost so 
that I can start trying to migrate some older blog content into it.

Outside the vhost section (as required), I have:

    FastCgiServer /path/to/typo/public/dispatch.fcgi -idle-timeout 120 \ 
         -initial-env RAILS_ENV=production -processes 10 

(My real directory is obviously there instead of that fake one. :-))

Problem is, I'm getting an error message on starting Apache:

    FastCgiServer /path/to/typo/public/dispatch.fcgi: User/Group commands
        must preceed FastCGI server definitions

Ignoring that the FastCGI developers can't spell "precede" properly, my 
User/Group definitions actually *do* precede my FastCGI server definitions.  
In fact, my User/Group definitions are included extremely early on from 
apache2.conf, whereas the vhosts are all included *after* all other includes.

I've tried adding the User and Group lines in a second time right before the 
same line, but the same error message comes up.

Presumably someone here has it working already, so you might spot something 
I'm doing something wrong that I can't instantly see.

My present workaround is to run Rails under lighttpd and proxy to it from 
Apache, but I think I'd rather have it running directly under Apache if 


             Email: Trejkaz Xaoza <trejkaz at trypticon.org>
          Web site: http://trypticon.org/
         Jabber ID: trejkaz at jabber.zim.net.au
   GPG Fingerprint: 9EEB 97D7 8F7B 7977 F39F  A62C B8C7 BC8B 037E EA73
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/typo-list/attachments/20050814/f8983681/attachment.bin

More information about the Typo-list mailing list