[typo] Dispatch failed to catch packets out of order

David Mytton david at mytton.net
Sat Aug 13 04:53:15 EDT 2005


Indeed. I get the same problem as with Typo - just hangs. In the http 
error log I get:

[Sat Aug 13 09:52:49 2005] [warn] FastCGI: (dynamic) server 
"/home/notes/public_html/rails/dispatch.fcgi" has failed to remain 
running for 30 seconds given 3 attempts, its restart interval has been 
backed off to 600 seconds
[Sat Aug 13 09:51:44 2005] [warn] FastCGI: (dynamic) server 
"/home/notes/public_html/rails/dispatch.fcgi" has failed to remain 
running for 30 seconds given 3 attempts, its restart interval has been 
backed off to 600 seconds
[Sat Aug 13 09:51:44 2005] [error] [client 212.159.106.74] FastCGI: 
incomplete headers (0 bytes) received from server 
"/home/notes/public_html/rails/dispatch.fcgi"
[Sat Aug 13 09:51:44 2005] [error] [client 212.159.106.74] FastCGI: comm 
with (dynamic) server "/home/notes/public_html/rails/dispatch.fcgi" 
aborted: (first read) idle timeout (30 sec)


Regards,

David Mytton
http://www.olate.co.uk



Justin Palmer wrote:
> The 'Hey you've put ruby on rails' message doesn't insure that  
> everything is working.  Remove the index.html file inside the public  
> directory for your
> test app and see if you get any errors.
> 
>  -Justin
> 
> On Aug 12, 2005, at 6:05 PM, David Mytton wrote:
> 
>> Hi,
>>
>> I have just got Rails installed on my dedicated server - Fedora  
>> Linux, cPanel, Apache 1.3.33, MySQL 4.1.13 mod_fastcgi 2.4.2 and  
>> latest Rails/Ruby.
>>
>> I have confirmed rails is working by creating a test application,  
>> which gives me the "Congratulations, you've put Ruby on Rails!"  
>> message. I then when to install Typo but when I access it via my  
>> browser, it hangs. The http error log shows:
>>
>> [Sat Aug 13 00:00:41 2005] [warn] FastCGI: (dynamic) server "/home/ 
>> notes/public_html/blog/dispatch.fcgi" has failed to remain running  
>> for 30 seconds given 3 attempts, its restart interval has been  backed 
>> off to 600 seconds
>> [Sat Aug 13 00:00:38 2005] [warn] FastCGI: (dynamic) server "/home/ 
>> notes/public_html/blog/dispatch.fcgi" has failed to remain running  
>> for 30 seconds given 3 attempts, its restart interval has been  backed 
>> off to 600 seconds
>>
>> and so on
>>
>> My dispatch.fcgi file has this in (ignoring the lines with #  
>> proceeding them)
>>
>> require File.dirname(__FILE__) + "/../config/environment"
>> require 'rubygems'
>> require_gem 'fcgi'
>> require 'fcgi_handler'
>>
>> RailsFCGIHandler.process!
>>
>> And my .htaccess is:
>>
>> # General Apache options
>> AddHandler fastcgi-script .fcgi
>> AddHandler cgi-script .cgi
>> Options +FollowSymLinks +ExecCGI
>>
>> # Redirect all requests not available on the filesystem to Rails
>> RewriteEngine On
>>
>> # Uncomment this if you're not running Typo in the root of your
>> # webserver's URL space (i.e. http://www.example.com/blog):
>> #
>> RewriteBase /blog/
>>
>> # try to suggest current rss subscribers that the url moved permently
>> RewriteRule ^xml/([a-z]+)$ /xml/$1/feed.xml [R=301]
>> RewriteRule ^$ index.html [QSA]
>> RewriteRule ^([^.]+)$ $1.html [QSA]
>> RewriteCond %{REQUEST_FILENAME} !-f
>> RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]
>>
>> # In case Rails experiences terminal errors
>> ErrorDocument 500 "<h2>Application Error</h2>Typo could not be reached
>>
>>
>> I tried running
>>
>> public/dispatch.fcgi
>>
>> whilst tailing log/fastcgi.crash.log:
>>
>>  [12/Aug/2005:23:55:37 :: 26559] starting
>> [12/Aug/2005:23:55:37 :: 26559] Dispatcher failed to catch: Packets  
>> out of order: 1<>3: SHOW FIELDS FROM sessions  
>> (ActiveRecord::StatementInvalid) /usr/local/lib/ruby/gems/1.8/gems/ 
>> activerecord-1.11.1/lib/active_record/connection_adapters/ 
>> abstract_adapter.rb:462:in `log' /usr/local/lib/ruby/gems/1.8/gems/ 
>> activerecord-1.11.1/lib/active_record/connection_adapters/ 
>> mysql_adapter.rb:130:in `execute' /usr/local/lib/ruby/gems/1.8/gems/ 
>> activerecord-1.11.1/lib/active_record/connection_adapters/ 
>> mysql_adapter.rb:108:in `columns' /usr/local/lib/ruby/gems/1.8/gems/ 
>> activerecord-1.11.1/lib/active_record/base.rb:622:in `columns' /usr/ 
>> local/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib/active_record/ 
>> base.rb:627:in `columns_hash' /usr/local/lib/ruby/gems/1.8/gems/ 
>> actionpack-1.9.1/lib/action_controller/session/ 
>> active_record_store.rb:71:in `setup_sessid_compatibility!' /usr/ 
>> local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/ 
>> session/active_record_store.rb:44:in `find_by_session_id' /usr/ 
>> local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/ 
>> session/active_record_store.rb:243:in `initialize' /usr/local/lib/ 
>> ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/session/ 
>> active_record_store.rb:243:in `silence' /usr/local/lib/ruby/gems/ 
>> 1.8/gems/actionpack-1.9.1/lib/action_controller/session/ 
>> active_record_store.rb:243:in `initialize'
>>   /usr/local/lib/ruby/1.8/cgi/session.rb:273:in `new'
>>   /usr/local/lib/ruby/1.8/cgi/session.rb:273:in `initialize' /usr/ 
>> local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/ 
>> cgi_process.rb:94:in `new' /usr/local/lib/ruby/gems/1.8/gems/ 
>> actionpack-1.9.1/lib/action_controller/cgi_process.rb:94:in  `session' 
>> /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/ 
>> action_controller/base.rb:737:in `assign_shortcuts' /usr/local/lib/ 
>> ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb: 
>> 351:in `process' /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/ 
>> lib/action_controller/rescue.rb:20:in `process_with_exception'
>>
>> /usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/dispatcher.rb: 
>> 34:in `dispatch' /usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/ 
>> fcgi_handler.rb:144:in `process_request' /usr/local/lib/ruby/gems/ 
>> 1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:64:in `process!' /usr/ 
>> local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:55:in  
>> `each_cgi' /usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/ 
>> fcgi_handler.rb:55:in `process!' /usr/local/lib/ruby/gems/1.8/gems/ 
>> rails-0.13.1/lib/fcgi_handler.rb:21:in `process!'
>>   public/dispatch.fcgi:26
>> [12/Aug/2005:23:55:37 :: 26559] terminated gracefully
>>
>> So I was wondering if anyone can help me with this problem?
>> -- 
>> Regards,
>>
>> David Mytton
>> http://www.olate.co.uk
>> _______________________________________________
>> Typo-list mailing list
>> Typo-list at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/typo-list
>>
>>
>>
> 


More information about the Typo-list mailing list