[typo] typo 2.5.3 on Dreamhost

K-Lai oneapproved at gmail.com
Sat Aug 13 01:34:03 EDT 2005


I followed the same steps to install Typo 2.5.3 on Dreamhost. 
Something is still acting up, because I get an "Application Error
Typo could not be reached" when I try to leave a comment on any of the
posts on my blog.

When I ran 'tail -f log/production.log' on SSH, I didn't see any
errors.  I got to the following message:

Processing ContentController#index (for 68.97.36.242 at Thu Aug 11
21:38:12 PDT 2005)
  Parameters: {"action"=>"index", "controller"=>"admin/content"}
Rendering  within layouts/administration
Rendering admin/content/list (200 OK)
Completed in 0.43355 (2 reqs/sec) | Rendering: 0.35420 (81%) | DB: 0.01566 (3%) 
[http://www.domain.com/admin/content]

which seemed ok.  When I ran 'ps axf', I got the following result:

  PID TTY      STAT   TIME COMMAND
 2324 pts/4    Ss     0:00 -bash
21442 pts/4    R+     0:00  \_ ps axf
 2411 ?        S      0:02 ruby dispatch.fcgi
20353 ?        S      0:02 ruby dispatch.fcgi
23931 ?        S      0:02 ruby dispatch.fcgi
 6555 ?        S      0:01 ruby dispatch.fcgi
 1913 ?        S      0:02 ruby dispatch.fcgi
 4131 ?        S      0:02 ruby dispatch.fcgi
24495 ?        S      0:09 ruby dispatch.fcgi
17779 ?        S      0:02  \_ ruby dispatch.fcgi
17529 ?        S      1:32      \_ ruby dispatch.fcgi
 5112 ?        S      0:01 /usr/bin/ruby dispatch.fcgi
22325 ?        S      0:03 /usr/bin/ruby dispatch.fcgi
 5609 ?        S      0:10  \_ /usr/bin/ruby dispatch.fcgi
 7637 ?        SN     5:29      \_ /usr/bin/ruby dispatch.fcgi

Do you have any other ideas?  The main page for this typo install
works just fine - it loads up super fast with the theme set up the way
I want it and everything.  It just won't let me leave comments (to the
point of not even letting me see a comment page), and it won't let me
access the admin page (www.domain.com/admin).

Thanks!
Kevin


I just installed Typo 2.5.3 on Dreamhost a couple of days ago, and
here are the basic steps I did :

1. Create your subdomain, e.g. blog.example.com, in the domain
settings, specify the path to the "public" directory of your Typo
2.5.3 installation. Enable FastCGI in the domain settings.
2. Be sure to have the correct settings in database.yml
3. Be sure to have your public dir and contents chmoded to 755.
4. Set RAILS_ENV = 'production' instead of the default "RAILS_ENV =
..." line in the config/environment.rb file

Everything should run fine. I had problems with 2.5.2 (as you may see
here before) but 2.5.3 just run fine for me on DH.

To be sure :
1. connect on DH through ssh
2. start a  'tail -f log/production.log' (production.log is created as
soon as you first visit your rails app in production mode) and look
for errors
3. visit your site
4. on DH host, do a 'ps axf' to see if you have dispatch.fcgi processes running



On 8/12/05, K-Lai <oneapproved at gmail.com> wrote:
> Hi,
>
> I just installed Typo 2.5.3 on a Dreamhost-hosted web domain.  I got
> everything working on WEBrick, but only the home page seems to work
> from my web browser.  If I want to access the admin panel, I need to
> start the WEBrick server on the remote server (script/server -e
> production).  I've found that posting comments only works when I'm
> running it from WEBrick too.
>
> I'm fairly new to all of this web-development stuff, so if anyone
> could help me figure this stuff out (as well as what error messages to
> find) that would be awesome!  I don't even know what messages I need
> to find to help you all diagnose the problem.
>
> Thanks,
> Kevin
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>



More information about the Typo-list mailing list