[typo] Again problems with 2.5.x

Jonathan Weiss jw at innerewut.de
Sat Aug 6 20:01:00 EDT 2005


After converting my typo-2.0.6 DB from a SQLite-DB to a MySQL-DB as
migrations are not supported with SQLite I tried to upgrade to 2.5.2.

The WEBrick mode works, but I have problems with Apache2/FastCGI. This
stetting worked flawlessly with 2.0.6.

It seems like that in the packages on rubyforge there is no .htacces file in
public but in svn-trunk there is one (and there are still the osx ressource

Without the .htaccess file I get an "not found" error while trying to access
an article.

I tried copying the file from svn but with it I get this error:

Application Errror
Typo could not be reached

This is a FreeBSD 5_STABLE machine with these settings:

LoadModule fastcgi_module libexec/apache2/mod_fastcgi.so
<IfModule mod_fastcgi.c>
    FastCgiIpcDir /tmp/fcgi_ipc/
    AddHandler fastcgi-script .fcgi
        FastCgiServer /usr/local/www/blog_innerewut_de/public/dispatch.fcgi
-initial-env RAILS_ENV=production

<VirtualHost *:80>
    ServerName blog.innerewut.de
    ServerAdmin admin at innerewut.de
    DocumentRoot /usr/local/www/blog_innerewut_de/public/
    ErrorLog /var/log/blog.innerewut.de-error_log
    CustomLog /var/log/blog.innerewut.de-access_log combined
        <Directory /usr/local/www/blog_innerewut_de/public/>
        Options ExecCGI FollowSymLinks
        AddHandler cgi-script .cgi
        AllowOverride all
        Allow from all
        Order allow,deny


Jonathan Weiss

More information about the Typo-list mailing list