[typo] Errors running script/server

Edwin Sheldon esheldon at hungsquirrel.org
Tue Apr 19 03:44:47 EDT 2005


Hello,

I am trying to install typo on Ubuntu Linux using ruby 1.8.2 and mysql
4.0.23.  I installed gems and used it to install rails (and its
dependencies) and redcloth, following the instructions, and edited the
appropriate config files.  However, when I ran script/server, I ran into
errors.  The errors continued after I also tried using the beta version of
rails.  Am I missing an important step?

Thanks for your time,
Edwin

--------------------------

$ ruby script/server
/usr/lib/ruby/gems/1.8/gems/actionpack-1.8.0/lib/action_controller.rb:52:
undefined method `template_class=' for ActionController::Base:Class
(NoMethodError)
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_support/dependencies.rb:197:in
`require'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:175:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:31:in `require_gem'
        from ./script/../config/environment.rb:33
        from script/server:45:in `require'
        from script/server:45



More information about the Typo-list mailing list