[typo] Route problems

Ioan Bizau jr. ib at sdf-eu.org
Sun Apr 3 12:32:34 EDT 2005

The problem is that Typo doesn't create feed.xml after it is deleted. I 
think it has nothing to do with RssBandit, because it worked once.
It has nothing to do with the mime; the file simply doesn't exist.
The directories are chmod 777.
If I put a "raise "xxx"" in xml_controller.rb method "rss" I get the 
same error, so it doesn't even arrive there. I need to find a way to 
determine webrick to call the controller code if the xml isn't there.

Tobias Luetke wrote:
> This could be the caching at fault. On the first request after an
> update to the database the XML is just dumped into the file system (
> /xml/rss/feed.xml for example )
> This has the advantage that further requests don't even have to be
> interpreted by typo anymore, the web server will just serve the
> document.
> Now the question is why does RSS Bandit have issues with this, i could
> imagine that Webrick might serve these cached feeds with the wrong
> mime type.
> Either way, try to delete the xml folder in your public dir and see if
> this is the issue.
> On Apr 3, 2005 11:24 AM, Ioan Bizau jr. <ib at sdf-eu.org> wrote:
>>Hey guys,
>>I am having trouble with the routes to feeds in Typo.
>>If I view /xml/rss/feed.xml in a webbrowser it works ok. After I try to
>>add the feed in RssBandit it becomes unusable, even from the browser. I
>>get the following message:
>>Routing Error
>>No route for path: "feed.xml"
>>Failure reasons:
>><ActionController::Routing::Route "" when {:controller=>"articles"}>
>>failed because unused components were left: feed.xml
>><ActionController::Routing::Route "xml/:action/feed.xml" ||
>>{:action=>"index"} when {:controller=>"xml"}> failed because value for
>>component "xml" doesn't match feed.xml
>><ActionController::Routing::Route "articles/:year/:month/:day/:title"
>>when {:controller=>"articles", :action=>"permalink"}> failed because
>>value for component "articles" doesn't match feed.xml
>><ActionController::Routing::Route ":controller/:action/:id" ||
>>{:id=>nil, :action=>"index"}> failed because no controller found at
>>subpath feed.xml
>>The strange thing is that now it doesn't work anymore, even if I restart
>>webrick. (!!) Very, very strange. I compare the files from my
>>installation with the original files and everything is unchanged. I
>>erase my installation, copy the original files, change my settings
>>and... it works! Until next time I try to add it in RssBandit. :-(
>>Any ideas?
>>Typo-list mailing list
>>Typo-list at rubyforge.org

More information about the Typo-list mailing list