[Tmail-talk] [ANN] TMail 1.2.2 - Ruby 1.9 Compatible & Documentation

Mikel Lindsaar raasdnil at gmail.com
Sat Mar 8 19:22:08 EST 2008


TMail - Mail Handling Library for Ruby
=================================

TMail is the Ruby Mail handler used in the Ruby on Rails and Nitro web
frame works as well as many others (now including, the Ruby Talk mail
gateway!).

TMail is now a gem. You can install it on any platform via:

# gem install tmail

Alternatively you can download the source code or view extra
documentation at the website:

http://tmail.rubyforge.org/


Release Summary:
------------------
TMail 1.2.2 is now compatible with Ruby 1.9 - all tests pass for both
Ruby 1.9 and Ruby 1.8.6.  Please test and report back any errors.

1.2.2 also brings DOCUMENTATION (yes, in capitals) revamped README,
and simplified documentation means that now you can fire up your Gem
server and view the TMail RDocs without having the schedule a 3 hour
break from your work to try and decipher them.  I have done a lot of
documentation (several thousand lines in total) however there is a
more to go and I would like any contributions out there :)

You can also now view the RDocs online at http://tmail.rubyforge.org/rdoc/

Also created a Contributing to TMail page at
http://tmail.rubyforge.org/contributing/ for those of you who want to
help but are not sure how.

Rails 2.0 now has a feature where it will use the gem version of TMail
if it detects a higher version than 1.2.1.  So anyone on Rails 2.0 can
upgrade to TMail 1.2.2 by simply doing gem install tmail and then
restarting their server.  Rails Edge will have the final TMail 1.2.2
changes merged in in the next few days.

Nitro users can simple gem install tmail to get the upgrade.

Additionally, several bugs were fixed from the tracker (see details below)

One set of API changes:

base64_encode and base64_decode have been renamed to base64_encode!
and base64_decode! as they were destructive on the receiver.
base64_encode and base64_decode have been created to be
non-destructive on the receiver.

Other than the API change, TMail should be API compatible with TMail 1.2.0


Release Update Details:
-------------------------

* Closed #18516 - Fix TMail::Mail#preamble, and add #preamble= (Charles Lowe)

* Closed #18515 - Removed ftools from test case (Charles Lowe)

* A _LOT_ more documentation to the main tmail classes (Mikel)

* Closed #18038 - Multiple froms not being parsed correctly, added a
test case to cover this and show the correct handling - (Mikel)

* Closed #17719 - Reading unix mailbox fails using File.truncate - (Mikel)

* Updated documentation for UNIXMbox.new (Mikel)

* Added another test case from ActionMailer into test_quote.rb (Mikel)

* Closed #17011-107004: 1.9 Compatibility bugs (Kornelius Kalnbach & Mikel)

* Closed #17044 - Fixed Minero's TODO: "allow this type of header:
"Minero A. <aamine at loveruby.net>" (Mikel)

* Closed #17045 - Fixed the Address class to pre quote the email
address 'mikel at me.com <mikel at me.com>' into '"mikel at me.com"
<mikel at me.com>' which handles this problem (Mikel)

See the changelog for previous changes.


Bug Reports / Fixes:
----------------------

As always, we really welcome any bug reports or code for patches you
have created. Please submit anything you find through our RubyForge
tracker project which you can get to from our website:

http://tmail.rubyforge.org/


We hope you enjoy this release!


Mikel & The Growing TMail Team


More information about the Tmail-talk mailing list