[Tioga-users] Trouble installing

Vincent Fourmond fourmond at gmail.com
Mon Dec 17 03:13:53 EST 2007


On Dec 17, 2007 12:16 AM, Ken Shen <kenshen at physics.ucsb.edu> wrote:
> Hi, I'm having problems installing Tioga.  Running ./QUICK_INSTALL yields:
> -----------
> checking for zlib.h... yes
> checking for compress() in -lz... no
> Error: you should have zlib (including development files) installed to
> build and run Tioga. You can get it there:
>   http://www.zlib.net/
> If that doesn't solve your problem, please report it on the Tioga tracker:
>   http://rubyforge.org/tracker/?group_id=701
> -----------
> I reinstalled zlib-1.2.3 from zlib.net, thinking that the zlib that came
> with Leopard might be funny.  So I have a libz.a in my /usr/local/lib.  I
> don't know if it matters, but I don't have a libz.a in my /usr/lib, I only
> have libz.dylib and various versions of that (libz.1, libz.1.1.3,
> libz.1.2.3).  Also, I have zlib.h in both /usr/include and
> /usr/local/include.

  Funny... There should be a file split/mkmf2.log produced during the
build process. Could you post it here, so we can get a better idea ?



More information about the Tioga-users mailing list