[Support-admins] FW: RubyForge offline

Tom Copeland tom at infoether.com
Fri Dec 15 15:15:33 EST 2006


FYI, this outage appears to have been caused by a lot of bots hitting
the ViewVC pages and triggering lots of complicated diff operations.
This drove the load average up to ridiculous levels, which caused the
machine to go offline, etc.  I've disabled ViewVC until I can get a good
solution to this problem; hopefully we can figure out a way to disable
only the more expensive operations.  We shall see...

Yours,

Tom

-----Original Message-----
From: Tom Copeland [mailto:tom at infoether.com] 
Sent: Thursday, December 14, 2006 2:39 PM
To: 'support-admins at rubyforge.org'
Subject: FW: RubyForge offline


Everything came back up after a reboot.  I'm not sure what went wrong;
there's nothing very interesting in the logs except some network card
errors about an hour before it went down.  And it seems to have
recovered from those just fine; the last message in the log before the
shutdown is:

Dec 14 12:56:04 rubyforge kernel: NETDEV WATCHDOG: eth0: transmit timed
out Dec 14 12:56:05 rubyforge kernel: e1000: eth0: e1000_watchdog_task:
NIC Link is Up 100 Mbps Full Duplex

The load today wasn't very high... I don't know.

Yours,

tom

-----Original Message-----
From: Tom Copeland [mailto:tom at infoether.com] 
Sent: Thursday, December 14, 2006 2:21 PM
To: ruby-talk ML
Subject: RubyForge offline


Hi all -

RubyForge is offline; we're investigating it.  Mirror information is
here:

http://tomcopeland.blogs.com/juniordeveloper/2006/10/rubyforge_down.html

Thanks for your patience,

Tom




More information about the Support-admins mailing list