[sup-talk] searching buffer

David J. Hamilton groups at hjdivad.com
Tue Nov 16 23:38:54 EST 2010


Excerpts from Brian May's message of Tue Nov 16 14:30:09 -0800 2010:
> On 17 November 2010 03:40, David J. Hamilton <groups at hjdivad.com> wrote:
> > You might want to retry with all of the messages open.  The search feature seems
> > to really only search the buffer, and not the “collapsed” text (e.g. message
> > body text in a closed message).  The same applies to hitting ‘n’ to advance to
> > the next search result.
> 
> Yes, tried that.
> 
> Like I said, 'n' hides all the existing search results.

In that case, my local copy of sup (v0.11 on ruby 1.8.7) is just behaving
differently from yours for some reason.  If I search for text using ‘/’,
subsequently hitting ‘n’ moves to the next instance.  However, if I hit
something like ‘j’ or ‘k’ then the search is unhighlighted and ‘n’ switches back
to its “Jump to next open message” function.

The only other thing I can think of is that when I run a search in a buffer that has
no results, ‘n’ never changes from its “Jump to next open message” function.


In any case, if somebody more knowledgeable than me gets to your question,
hopefully they can shed some light on how one can do a search (in a thread
buffer) of an entire thread's content, and not merely the content of the open
messages.

-- 
med vänlig hälsning
David J. Hamilton


More information about the sup-talk mailing list