[sup-talk] error on loading a saved index

jeff covey jeff.covey at pobox.com
Sun Jun 10 14:12:56 EDT 2007


after my ~/.sup/sources.yaml was wiped out, i tried sup-adding all my
sources and running sup-sync --changed on them, but got the ferret error
again.

so i removed ~/.sup/ferret/* and started from scratch.  i built my index and
tried to restore its state with the sup-dump backup from the night before.
everything went well for a time, then it died with this error:

ruby -I lib -w bin/sup-sync --restored --restore sup-backup-2007-06-08-22:08:15

...
Scanning mbox:///home/jeff/mail/invoice@icgroup.com-2007-06...
Scanned 2, added 0, updated 2 messages from mbox:///home/jeff/mail/invoice@icgroup.com-2007-06.
Restored state on 2 (100.00%) messages.
Scanning mbox:///home/jeff/mail/jchalmers@corp.sourceforge.com-2007-06...
Scanned 1, added 0, updated 1 messages from mbox:///home/jeff/mail/jchalmers@corp.sourceforge.com-2007-06.
Restored state on 1 (100.00%) messages.
Scanning mbox:///home/jeff/mail/jeff.covey@pobox.com-2007-06...
[Sat Jun 09 11:05:59 -0400 2007] saving index and sources...
[Sat Jun 09 11:06:00 -0400 2007] unlocking /home/jeff/.sup/lock...
bin/sup-sync:152: undefined method `sort_by' for nil:NilClass (NoMethodError)
        from ./lib/sup/poll.rb:115:in `add_messages_from'
        from ./lib/sup/source.rb:91:in `each'
        from ./lib/sup/util.rb:349:in `send'
        from ./lib/sup/util.rb:349:in `__pass'
        from ./lib/sup/util.rb:338:in `method_missing'
        from ./lib/sup/poll.rb:95:in `add_messages_from'
        from ./lib/sup/util.rb:313:in `send'
        from ./lib/sup/util.rb:313:in `method_missing'
        from bin/sup-sync:133
        from bin/sup-sync:128:in `each'
        from bin/sup-sync:128


[so i had to find and manually label messages in sup which had labels in the
backup.  the bright side is that i'm getting good at writing scripts to fix
sup when it falls down.  :)]

thanks,

-- 
jeff covey
http://jeffcovey.net/



More information about the sup-talk mailing list