[Rubyinstaller-devel] Ruby Installer for 64-bit Windows?

Luis Lavena luislavena at gmail.com
Tue Sep 22 18:21:42 EDT 2009


On Wed, Sep 23, 2009 at 12:13 AM, Nikolai Weibull <now at bitwi.se> wrote:
> Are there any plans for a Ruby installer for 64-bit Windows,
> preferably along with a devkit?
> Has anyone tried putting this together?

Hello Nikolai,

The only version of Ruby that supports compilation for x64 is 1.9.x

Yes, there are plans, which I'm partially working as a side
playground, but no official or timeline planned. Lot of things needs
to be fixed so don't expect that happen before 1.9.2 get released on
December.

I'm using mingw-w64 project for it, but still lot of things to be
ironed out in Ruby itself to be production quality.

I've CC'ed the Google Group, which I recommend you join instead of old
RF mailing list:

http://groups.google.com/group/rubyinstaller

Regards,
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubyinstaller-devel mailing list