[Rubyinstaller-devel] Heroku

Luis Lavena luislavena at gmail.com
Thu May 28 14:09:05 EDT 2009


On Thu, May 28, 2009 at 2:26 PM, Charles Roper
<reachme at charlesroper.co.uk> wrote:
> Luis Lavena wrote:
>>
>> One of the glitches with Heroku is not Heroku itself but json.
>>
>> I'll really great someone contact the json gem author and make him
>> upgrade the gem to use rake-compiler, so native binaries can be
>> distributed (hint hint)
>
> Hehe, I contanted Florian, the author, and he got back sounding a little
> confused saying he was already using rake-compiler. Turns out, JSON 1.1.6 is
> working fine on Windows (mingw32 and mswin32). Look:
>

Awesome! added to the list of gems using rake-compiler:

http://wiki.github.com/luislavena/rake-compiler/projects-using-rake-compiler
> [...]
>
> How would he go about providing a native mingw extension?
>

In version 0.5.0 of rake-compiler he can target both mingw32 and mswin32.

Exact documentation for now:

http://github.com/luislavena/rake-compiler/commit/166800107d24fa41474c1dc0a93df238f16563df

>
> BTW, what is the canonical way of detecting for Windows these days? Is it
> like this?
>
> RUBY_PLATFORM =~ /mswin32|mingw32/
>

Yes: /mingw|mswin/

The "32" part should be avoided, since there is mswin64_90 version
(VC9) and also mingw64 (which need to get it properly working).

> Cheers,
> Charles

Cheers and thank you for all the administrative effort getting in
touch with json author,

-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubyinstaller-devel mailing list