[Rubyinstaller-devel] question about devkit and note about readline files

Luis Lavena luislavena at gmail.com
Tue May 26 20:48:21 EDT 2009


On Tue, May 26, 2009 at 6:59 PM, Patrik Sundberg
<patrik.sundberg at gmail.com> wrote:
>
> Hi,
> I tried to post the below to the rubyinstaller-dev mailing list but looking
> at the archives it doesn't seem to have reached the list. I just wanted to
> check if it reached the list or if it never made it. I subscribed myself to
> the list just now, but not sure if I should attempt to repost it or if it
> already arrived.

Hello Patrik.

Indeed the message didn't arrive the list, which requires you to join.

Soon I'm going to open a Google Groups for this with the goal of
better manage the subscription and also simplify the process of people
reporting issues like yours.

Please read my inline answers to your questions. I'm CC'ing to
RubyInstaller-devel list so others can learn from those.

> Thanks,
>  Patrik
>
> ---------- Forwarded message ----------
> From: Patrik Sundberg <patrik.sundberg at gmail.com>
> Date: Mon, May 25, 2009 at 10:23 PM
> Subject: Re: question about devkit and note about readline files
> To: rubyinstaller-devel at rubyforge.org
>
>
> A follow up:
> When I run irb in the sandbox (sandbox\ruby18_mingw\bin) keys such as ctrl-a
> for start of line, ctrl-e for end of line, etc works fine. From the irb
> installed by the msi I no longer have those features. Sounds like this could
> be related to the readline issues so wanted to mention this as well. I'm
> executing "irb" while standing in the bin directory of the sandbox and the
> installed interpreter.
>

Unless you build the MSI installers using the updated-installers
branch, the built MSI packages are set to failure.

http://blog.mmediasys.com/2009/05/05/rubyinstaller-state-of-one-click/
(see Installers topic)

I suggest you use the 7z packages instead of the MSI.

http://blog.mmediasys.com/2009/05/17/rubyinstaller-updated-packages-and-other-news/

> On Mon, May 25, 2009 at 10:10 PM, Patrik Sundberg
> <patrik.sundberg at gmail.com> wrote:
>>
>> Hi,
>> (I'm not a list subscriber so please include me on any replies.)
>> I just got myself a new little netbook with windows xp on it and decided
>> to get ruby onto it. Doing a bit of research it seemed going the mingw route
>> was the way of the future so I followed various posts from Luis and Akira
>> and got myself sorted out. Got a couple of observations and questions (at
>> the end):
>>
>> rake CHECKOUT=1
>>    worked fine and produced a 1.8.6 interpreter. I had one error when
>> running it from a Console2 session at first - seems the "sh" method of rake
>> didn't quite agree with that session for some reason. switching to cmd.exe
>> fixed it. Thought I'd write it down in case anyone other Console2 user runs
>> into the same problem.

That definitely is a old version of Rake and Ruby that generated that.
Rake prior to 0.8.4 and/or Ruby 1.8.6-p287 has failures with
Kernel::system() and that translate into Rake "sh".

Solution: use one of the 7zip packages when building :-)

>> rake package
>>   this gave me two problems with the references to non-existant
>> readline5.dll and readline.so files in the .wxs files. I just removed those
>> entries in the xml files and it produced an msi that installs fine. some
>> simple tests are ok.

If you used master branch, those files are no more. Check the
updated-installers branch. The MSI packages really need some love :-P

>> Is the readline issue with rake package related to moving to rbreadline
>> and that change not having made it into the wxs files yet? I thought I saw
>> something on a blog about rbreadline so thought I'd check if it's related or
>> if something is going wrong on my side with the readline files. (btw, the
>> same goes for ruby19 that I had a quick go at compiling)

Yes. the WXS files need to be updated to include the pure-ruby
readline. All the work on that has been done on updated-installers
branch, not master.

Solution: Unless you really need to generate and run the installers,
stick to the 7zip packages.

On top of these packages, install the rb-readline 0.1.2:

http://blog.mmediasys.com/2009/05/19/pure-ruby-readline-released-012/

>> In general I have to say great work in stitching up the build process of
>> the while thing into a neat set of rake tasks - thanks!

Thank you, there are still a lot of glitches :-P

>> My question is with regards to the devkit. The msi file is just the ruby
>> parts, it doesn't contain the devkit. I was hoping to get a msi with both
>> ruby and mingw so that I have one file installing everything needed to start
>> hacking away in ruby and the tools for building native extension for the
>> gems that need them. Reading various blog posts I got the impression that
>> some have produced *devkit.msi files. Is there a rake task for this or am I
>> off base here? What's the typical way of installing the devkit outside of
>> the sandbox environment?

I'll suggest stay away of devkit package. DevKit is dead. I've
actually killed that package in updated-installer branch.

>> I was going to suggest the devkit could be made into a gem (including just
>> some rake tasks), but some googling showed that Luis already suggested this.

Yes, we are going the devkit gem route, but is not ready for prime-time yet. :-P

>> Can't find any follow ups on the thread. It seems like a really neat idea to
>> me, and it'd make my paragraph above void.

:-D

>> Thanks a lot for working on rubyinstaller!

Thank you for your feedback!
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubyinstaller-devel mailing list