[Rubyinstaller-devel] Updated MySQL and SQLite3 gems for Mingw

Luis Lavena luislavena at gmail.com
Sat May 16 18:51:50 EDT 2009

On Sat, May 16, 2009 at 7:45 PM, Mike Hodgson <mhodgson at gmail.com> wrote:
> Hi All,

Hello Mike

> I've switched both of my Windows (XP and Vista) machines over to the
> new mingw32 Ruby, and have so far had no problems!

Awesome to hear! I use it on a daily basis without issues, which means
is going to be more easy the migration now that assimilation (err,
adoption) has started!

> I built the lastest MySQL and SQLite3 gems for my own use, and thought
> I might share with others:
> http://www.mikehodgson.com/gems/
> I've got the process down to a fine art, so if anyone out there has
> any requests, I'm all ears!

Did you based those in mysql-gem[1] and sqlite3-ruby[2] fork I have at github?

MySQL 5.1 is incompatible with the gem, lot of segfaults that I can
blame the extension itself (since DataMapper guys don't face those).

The one in sqlite3-ruby is based on Jamis work and uses rake-compiler.

Can you share the steps you used to build those? I would really love
to integrate and get the smoother experience for everybody!


[1] http://github.com/luislavena/mysql-gem
[2] http://github.com/luislavena/sqlite3-ruby

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubyinstaller-devel mailing list