[Rubyinstaller-devel] GCC 4.3

Luis Lavena luislavena at gmail.com
Tue Mar 31 17:52:13 EDT 2009

On Tue, Mar 31, 2009 at 5:47 PM, deepj <deepjungle.maca at gmail.com> wrote:
>> Yeah that's the one I linked to as an option :)
>> How to reproduce the EM errror?
> You can run EventMachine tests using rake:test. When I run it EventMachine
> will stop responding (I must kill it). The compile seems to be fine, only a
> few warnings.
> Maybe the  problem is in OpenSSL libraries. I've used OpenSSL 0.9.8j from
> this place http://www.slproweb.com/products/Win32OpenSSL.html (the full
> installation contains dev files for mingw) when I compiled Ruby 1.9.1. Can
> you try it and you can confirm it if the problem in this?
> I'm sorry for my ugly english :)

I believe that version of OpenSSL is linked with MSVCR80/90, not
msvcrt, which is used by MinGW). Be careful using those binaries.

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubyinstaller-devel mailing list