[Rubyinstaller-devel] Optional DevKit gem install request

Jon jon.forums at gmail.com
Tue Jun 30 14:36:59 EDT 2009


> Thank you Jon for your write up. I need to think a little bit more on
> this, since ideally DevKit gem and the installation of the components
> should be shared across versions of ruby.


I'm wondering if the installer and the gem might be built to behave similar to how RubyGems behaves?

Specifically, the current Ruby binaries come preinstalled with RubyGems 1.3.1 and then one can do "gem update --system" to update to 1.3.4.  Both versions appear to be installed in Ruby, but the latest RubyGems wins out over the preinstalled RubyGems.

I haven't looked into it and I'm a bit new to Ruby, but is there a search ordering of $: that we could use to our advantage?

In 1.9 doesn't the "gems" directory override the "site-ruby" directory which override the "vendor-ruby"?  Maybe the DevKit optionally installed from OCI can be placed in "site-ruby" and any updates would get placed in "gems".

Maybe this isn't how things work, but just a thought...


More information about the Rubyinstaller-devel mailing list