[Rubyinstaller-devel] eventmachine gem can not work with OCI 1.9.1p129

Luis Lavena luislavena at gmail.com
Wed Jul 29 11:40:03 EDT 2009

2009/7/29 phoenix <wujunchen at gmail.com>:
> I can install eventmachine in  OCI 1.9.1p129 with --platform=mswin32,but
> eventmachine can not work in this way.
> And if install it not use --platform=mswin32,it can not be installed.

That is because you're trying to install a binary version of
eventmachine that has been built for Ruby 1.8.6

Unless EventMachine is built with "fat-binaries" to support both 1.8
and 1.9, the gem will not work.
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubyinstaller-devel mailing list