[Rubyinstaller-devel] Wiki: Gem lists and misleading details

deepj deepjungle.maca at gmail.com
Sat Jul 25 17:53:31 EDT 2009


I'm sorry, it should be nokogiri instead of mongodb-mongo. It was my 
mistake.

Dne 25.7.2009 23:32, Luis Lavena napsal(a):
> Hey Guys,
>
> I noticed a couple of this on the wiki page:
>
> http://wiki.github.com/oneclick/rubyinstaller/gem-list
>
> "7/22/09	Mongodb-mongo	0.9	1.3.4	4.3.3	WinXP Prof	OK	built via TDM-GCC"
>
> MongoDB does not need a compiler to be installed.
>
> C:\Users\Luis\Projects\oss\rubyspec>gem spec mongodb-mongo extensions
> --- []
>
> Even so, stating "built via TDM-GCC" is misleading, since there is no
> compilation or build process involved.
>
> MongoDB ruby adapter is a Pure-Ruby solution that connects to MongoDB
> using HTTP.
>
> Adding those details raises some eyebrows since you are automatically
> bumping the complexity of the end-user experience and the steps they
> will need to take care prior installing something.
>
> So avoid stating a compiler was required or which one was used when
> there is no need for a compiler.
>
> Thank you.


More information about the Rubyinstaller-devel mailing list