[Rubyinstaller-devel] Building the Character-encodings gem on windows

Luis Lavena luislavena at gmail.com
Tue Feb 10 21:21:17 EST 2009

On Tue, Feb 10, 2009 at 8:05 PM, Jon <snoodger4eva at yahoo.com> wrote:
> Hi all,
> I'm using the ruby dev kit installer available on Akita's blog
> (http://www.akitaonrails.com/2008/7/26/still-playing-with-ruby-on-windows).
> After installing it, I updated the ruby gems to version 1.3.1 and installed
> rails 2.2.2.
> My goal was to have a build environment so that I could install the
> character-encodings gem for windows xp. I need this gem to be able to use
> rfeedparser. When I try to install character-encodings, it starts the build
> and then chokes at the make part. I've also tried this in cygwin, with the
> same error, and now I'm at my wit's end! J
> Have any of you ever successfully installed the character-encodings gem on
> windows using the environment created by the ruby installer, or do you know
> anyone who has? I've googled extensively and found nothing helpful.

Just tried to build using gcc 3.4.5 an 1.8.6-p114 (mingw):


Taking in consideration Roger comments and that output, looks like
something needs to be tweaked in the encoding files itself.

Wonder if these encoding files originally were a shared object
(so/dll) and they merged with the extension.

I'll take a look later this week. Looks interesting to get it working,
but I'm in the middle of a hectic week :-P

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubyinstaller-devel mailing list