[Rubyinstaller-devel] current mingw make test results

Luis Lavena luislavena at gmail.com
Thu Nov 13 06:03:23 EST 2008


On Mon, Nov 10, 2008 at 4:41 AM, Roger Pack <rogerpack2005 at gmail.com> wrote:
> I assume these errors are common?
>
> for the default [from git--1.8.6]
>
> 1607 tests, 15685 assertions, 5 failures, 72 errors (lots of soap errors)
>
> and for the same with rake CHECKOUT=1
>
> 1632 tests, 16038 assertions, 6 failures, 0 errors
>
> sometimes 5 failures, sometimes 6.  I assume the ssl error [the 6th]
> is timing related? [like the server closes too fast in some instances
> or something?]  It seems hard to reproduce.
>
> Do you think the rest of these are bugs in ruby or in ruby mingw?
> I'm afraid I'll hurt the MSVC distro if I try and fix them :)
>
> As a side note, I also get the old "mingw -e quoted fails" stuff just
> like I used to--I knew I wasn't going crazy :)
>
> ruby 1.8.6 (2008-07-17 patchlevel 279) [i386-mingw32]
>
> ruby -e "20.times { \"a\"}"
> -e:1: syntax error, unexpected tSTRING_BEG, expecting $end
> 20.times { "a"}"►
>
> Thanks.
> -=R


Can you tell me which console are you using? which codepage? I tried
to reproduce your problem several times without luck. Used standard
command prompt and Console2

The only one I didn't tried is rxvt with bash since they have serious
issues (I suggest you use directly bash with console2 to get a nicer
tabbed console).

-- 
Luis Lavena
AREA 17
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Rubyinstaller-devel mailing list