[Rubyinstaller-devel] err on build

Roger Pack roger.pack at leadmediapartners.com
Mon Nov 3 18:41:36 EST 2008


I'll probably look into this sometime.
after doing git clone, rake


...
** Invoke sandbox/ruby_mingw (not_needed)
** Execute tools:rubygems:install
cd sandbox/rubygems
ruby setup.rb install --no-ri --no-rdoc
--destdir=c:/dev/rubyinstaller_clone/sandbox/rubygems_mingw
mkdir -p c:/dev/rubyinstaller_clone/sandbox/rubygems_mingw/c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/site_ruby/1.8
c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:243:in
`mkdir': Invalid argument -
c:/dev/rubyinstaller_clone/sandbox/rubygems_mingw/c: (Errno::EINVAL)
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:243:in
`fu_mkdir'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:217:in
`mkdir_p'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:215:in
`reverse_each'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:215:in
`mkdir_p'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:201:in
`each'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:201:in
`mkdir_p'
        from c:/dev/rubyinstaller_clone/sandbox/ruby_mingw/lib/ruby/1.8/fileutils.rb:1527:in
`mkdir_p'
        from setup.rb:141
rake aborted!
Command failed with status (1): [ruby setup.rb install --no-ri --no-rdoc --...]
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:971:in `sh'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:984:in `call'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:984:in `sh'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1072:in `sh'
c:/dev/rubyinstaller_clone/recipes/tools/rubygems.rake:58
c:/Ruby18/lib/ruby/1.8/fileutils.rb:121:in `chdir'
c:/Ruby18/lib/ruby/1.8/fileutils.rb:121:in `cd'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1072:in `cd'
c:/dev/rubyinstaller_clone/recipes/tools/rubygems.rake:57
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `call'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `execute'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `each'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `execute'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/1.8/monitor.rb:242:in `synchronize'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in `each'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/1.8/monitor.rb:242:in `synchronize'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in `each'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/1.8/monitor.rb:242:in `synchronize'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in `invoke'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in `invoke_task'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `top_level'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `each'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `top_level'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in `top_level'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in `run'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
c:/Ruby18/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
c:/Ruby18/bin/rake:19:in `load'
c:/Ruby18/bin/rake:19

c:\dev\rubyinstaller_clone>


-- 
Thanks!
-=R


More information about the Rubyinstaller-devel mailing list