[Rubyinstaller-devel] problem installing the mingw sandbox

Luis Lavena luislavena at gmail.com
Thu May 15 20:33:13 EDT 2008

On Wed, May 14, 2008 at 9:13 PM, Luis Lavena <luislavena at gmail.com> wrote:
> On Wed, May 14, 2008 at 9:07 PM, Roger Pack
> <roger.pack at leadmediapartners.com> wrote:
>> as a note--
>> ruby setup.rb install --no-ri --no-rdoc RUBYOPT=
>> ruby: no such file to load -- ubygems (LoadError)
>> rake aborted!
>> Command failed with status (1): [ruby setup.rb install --no-ri --no-rdoc RU...]
>> (See full trace by running task with --trace)
>> hmm.
> That's because previous installation of Ruby set RUBYOPT with
> rubygems, and there is no easy way to remove that when installing
> rubygems into the sandboxed ruby.
> Can you removing the RUBYOPT= from config/ruby_installer.rb file? (line 147).
> Latest RubyGems 1.1.1 workaround that issue, dunno why that was still present.
> Let me know if it worked, if not, please fill a ticket at rubyforge,
> I'll take care of it during the weekend.

Roger, that worked?

Please let me know so I can correct the installer3 recipes.
Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Rubyinstaller-devel mailing list