[Rubyinstaller-devel] mingw openssl test failure

Gordon Thiesfeld gthiesfeld at gmail.com
Wed Jun 4 13:10:11 EDT 2008


On Tue, Jun 3, 2008 at 5:44 PM, Roger Pack <rogerpack2005 at gmail.com> wrote:
> Downloaded a fresh install of mingw today and got this:
>
> C:\downloads\latest\installer3>rake check
> (in C:/downloads/latest/installer3)
> "C:/downloads/latest/installer3/sandbox/msys/bin/bash.exe" --login -i
> -c "make check"
> test succeeded
> ./miniruby.exe  ../ruby_1_8/runruby.rb --extout=.ext --
> "../ruby_1_8/test/runner.rb" --basedir="../ruby_1_8/test"
> --runner=console
>
> Loaded suite .
> Started
> ..................................................................................................................................
> ..................................................................................................................................
> ...................../ruby_1_8/test/openssl/test_hmac.rb:30: [BUG]
> Segmentation fault
> ruby 1.8.6 (2008-03-03) [i386-mingw32]
>
>
> This application has requested the Runtime to terminate it in an unusual way.
> Please contact the application's support team for more information.
>
>
> Anybody seen that before?

Actually, I just remembered I have seen that before ;-).  I was having
the same problem a few months ago, which was caused by having another
version of libeay32.dll and libssl32.dll in my system path.  Luis
helped me with it on this thread:

http://rubyforge.org/pipermail/rubyinstaller-devel/2008-April/000277.html

Hope that helps,

Gordon


More information about the Rubyinstaller-devel mailing list