[Rubyinstaller-devel] my old gripe :)

Roger Pack roger.pack at leadmediapartners.com
Tue Jun 3 20:11:39 EDT 2008


I'm slightly confused as to how to use gems with the latest git mingw installer.

I'd think that I should be able to run

c:\dev\latest\rubyinstaller\sandbox>  rubygems_mingw\bin\gem.bat list

and it would show 'no gems listed'
It defaults instead to using the installed msvc ruby.exe
Glancing at it I assume we have to install to c:\Ruby now?

Here's my attempt to run it with the right ruby.exe

c:\dev\latest\rubyinstaller\sandbox>ruby_mingw\bin\ruby.exe
rubygems_mingw\bin\gem
rubygems_mingw/bin/gem:8:in `require': no such file to load --
rubygems (LoadError)
        from rubygems_mingw/bin/gem:8


As a side note, you may also you may want to consider a few more
explicit directory names, since they were somewhat confusing to me
this [and every] time.
ruby_1_8 -> ruby_1_8_src
rubygems -> rubygems_src

To avoid confusion.
I could do it if you want.

Thanks!
-R


On Tue, Jun 3, 2008 at 5:33 PM, Roger Pack
<roger.pack at leadmediapartners.com> wrote:
> thanks.
> I took the liberty of doing some readline research.  Probably all
> useless, but...
> http://betterlogic.com/roger/?p=312
> there they are.  I might try them out sometime.  If I
>
> Note that I get the same hmac segfault using a clone of the github repo.
> -R
>
>
> On Tue, Jun 3, 2008 at 5:07 PM, Luis Lavena <luislavena at gmail.com> wrote:
>> On Tue, Jun 3, 2008 at 8:00 PM, Roger Pack
>> <roger.pack at leadmediapartners.com> wrote:
>>> could you drop me a link to the discussion?
>>
>> http://rubyforge.org/pipermail/rubyinstaller-devel/2008-April/000288.html
>>
>> And before I run out of battery, grab the tarball from github and use
>> that instead:
>>
>> http://github.com/luislavena/rubyinstaller/
>>
>> --
>> Luis Lavena
>> AREA 17
>> -
>> Human beings, who are almost unique in having the ability to learn from
>> the experience of others, are also remarkable for their apparent
>> disinclination to do so.
>> Douglas Adams
>>
>


More information about the Rubyinstaller-devel mailing list