[Rubyinstaller-devel] OpenSSL update & curses support

Gordon Thiesfeld gthiesfeld at gmail.com
Sun Jul 6 21:08:33 EDT 2008

On Sun, Jul 6, 2008 at 9:20 AM, Lars Christensen <larsch at belunktum.dk> wrote:
> The OpenSSL library that is used for the rubyinstaller is very old. I have
> added a rake recipe to build openssl from source
> (http://github.com/larsch/rubyinstaller/commits/opensslbuild). The biggest
> problem is that it depends on a Perl installation, and the MSYS perl doesn't
> work. I have not been able to find a Perl package for windows that is easily
> downloadable & installable into the sandbox. Another small issue is that you
> need to clean up the PATH environment let it find mingw and nothing but
> mingw (the recipe does this). Other than that it appears to work.

This is good news.  I've tried building OpenSSL a few times, but never
had much luck with it.  As far as Perl goes, have you tried Strawberry
Perl[1]?  I don't know much about the different Perl packages, but
Strawberry has a zip file available.  Just a thought.

[1] http://strawberryperl.com/releases.html



More information about the Rubyinstaller-devel mailing list